TP-Link MR3020 SSH Issue (I botched it's IP)

Posted by Detolin 
TP-Link MR3020 SSH Issue (I botched it's IP)
March 20, 2012 01:35PM
Hello everyone, just another guy trying to set up his PirateBox without knowledge of vi, telnet, ssh (and from the issue here, IP addresses as well) Using both Macbook and PC running Windows 7 and these forums I figured out vi as well as the basics to connecting via telnet then ssh (both MUCH easier on the Mac for those that have the option) I got the best answers from the threads of others posting their issues so I figured at the very least my post will deter others from making the same mistakes confused smiley

I was stuck at Step #14 (cross-referencing between both tutorials) My home network is rather complex to the point of being set up by an IT from work and I'm learning as much about his settings as I'm figuring out this PirateBox, but basically nothing was working using 192.168.1.1 other than ssh to the router connected directly to the mac through ethernet. So i started tinkering, and it being after 2am my brain decided to forget that addresses don't go above the figure 255

Here's my mess-up. I went back into network config and changed some things around...

Original
config interface 'loopback'
option ifname 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'

config interface 'lan'
option ifname 'eth0'
option type 'bridge'
option proto 'static'
option ipaddr '192.168.1.1'
option netmask '255.255.255.0'
option gateway '192.168.1.11'
list dns '192.168.1.11'
list dns '8.8.8.8'

config interface 'wan'
option ifname 'etho.1'
option proto 'dhcp'
option gateway '192.168.1.11'
option netmask '255.255.255.0'
list dns '192.168.1.11'
list dns '8.8.8.8'

-----------------------------------
Mine
config interface 'loopback'
option ifname 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'

config interface 'lan'
option ifname 'eth0'
option type 'bridge'
option proto 'static'
option ipaddr '192.168.150.991'
option netmask '255.255.255.0'
option gateway '192.168.150.999'
list dns '192.168.150.999'
list dns '8.8.8.8'

config interface 'wan'
option ifname 'etho.1'
option proto 'dhcp'
option gateway '192.168.150.999'
option netmask '255.255.255.0'
list dns '192.168.150.999'
list dns '8.8.8.8'

Using my Mac, under Network preferences it now shows my MR3020 saying "Self-Assigned IP"
IP Address: 169.254.223.62
Subnet Mask: 255.255.0.0

I've tried SSH like usual to these IP's as well as the ones i set up (192.168.150.991 & 999) nothing is working, it gives me either "port 22: Connection refused" or "port 22: Operation timed out" after a long wait each time. I've attempted other ports (23 & 24) with no change as well.
ihavenoideawhatimdoing.jpg

I can only guess it might be the "new" Subnet Mask but the past 4 hours of googling/research are giving me nothing as to how to fix it.
Am I SOL or is there still hope for this poor tiny router?



Edited 1 time(s). Last edit at 03/20/2012 07:34PM by Detolin.
Re: TP-Link MR3020 SSH Issue (I botched it's IP)
March 20, 2012 01:48PM
First step:
Find out what your home-net ip is: Go to your windows pc. Push start and enter "cmd" .. a commando-box opens. Enter
ipconfig
Here you might find a 192.168.x.y or a 10.x.y.z IP Adress. Please post your output.

Second step:
choose a IP at your range figured out at step 1
Reconfigure your ip at the router (hopefully it is still accessible, because IP-parts between the dots are not allowed above 254)

You find some useful informations about Ip-Adresses on wikipedia- Ip-Adress
Re: TP-Link MR3020 SSH Issue (I botched it's IP)
March 20, 2012 02:29PM
ipconfig shows this on my home network-
IP Address: 192.168.150.145
Subnet Mask: 255.255.255.0
Default Gateway: 192.168.150.1

that second step at "Reconfigure your ip at the router" is where I'm at now. I changed the IP on my home network above, it's still running fine.
My MR3020 is showing no change when connected to PC using ipconfig/all and I am still unable to connect into it via ssh using PuTTY

DHCP Enabled: Yes
Autoconfiguration Enabled: Yes
Autoconfiguration IPv4 Address: 169.254.223.62
Subnet Mask: 255.255.0.0
Default Gateway: (nothing here)



Edited 3 time(s). Last edit at 03/20/2012 07:36PM by Detolin.
Re: TP-Link MR3020 SSH Issue (I botched it's IP)
March 21, 2012 12:26AM
oh, very bad If you don't have an access. With your 999-IP you broke the routers configuration.
Try to bootthe router somehow into failsave mode to get a basic IP-Adress configuration ( i.e. 192.168.1.1 )
Re: TP-Link MR3020 SSH Issue (I botched it's IP)
March 21, 2012 04:35AM
IP addresses never go beyond 255.
Re: TP-Link MR3020 SSH Issue (I botched it's IP)
March 21, 2012 07:45AM
I have been trying for days to re-establish a connection to my mr3020
I too am stuck at step 14 but in my case I am unable to re-edit the network config file
I made the mistake of using my home network router's ip address instead of the gateway.

I feel that this is a common problem for us noobs.
the instructions could be a little more clear, seems most people who have an issue
it happens at step 14.

I have posted in my own thread and other people experiencing the same problem but
I haven't had much luck getting help.

I asked an IT guy at work and he says maybe I can use a cross over cable to connect to it
but im not sure about that.

If I could only get it to connect so I can re-edit that file, i'm so close...
i got same problem as you, and now am stuck with this ip 169.254.85.242 and can't log in to its cp.... any help here ...hot smiley
Re: TP-Link MR3020 SSH Issue (I botched it's IP)
September 23, 2012 11:20AM
Re: TP-Link MR3020 SSH Issue (I botched it's IP)
September 24, 2012 08:02AM
I did this and I was able to recover. Hold the button down on the MR3020 the second it starts to blink. It will begin blinking faster. Now it's in failsafe mode. You should be able to connect to it via ethernet and connect via the telnet directions. Be sure to do that mount command so it's writable (I think). It's fixable!
Author:

Your Email:


Subject:


Spam prevention:
Please, enter the code that you see below in the input field. This is for blocking bots that try to post this form automatically. If the code is hard to read, then just try to guess it right. If you enter the wrong code, a new image is created and you get another chance to enter it right.
Message: