Bricked MR3040

Posted by tombstones 
This forum is currently read only. You can not log in or make any changes. This is a temporary situation.
Now, this forum is in read-only mode. You find details Details hereContinue on /r/PirateBox
Re: Bricked MR3040
February 09, 2016 09:27PM
so, if you haven't messed it up completely, you should still be able to use a serial adapter and see uboot messages, don't you?
Re: Bricked MR3040
February 09, 2016 09:32PM
In that case I have messed it up completely, because when I hook up the serial adapter, I get a connection timeout, no uboot, nothing.
Re: Bricked MR3040
February 10, 2016 06:12AM
Connection timeout sounds more like a problem with your TTL adapter.. to be honest.

The TTL connection usually don't get a timeout.
Re: Bricked MR3040
February 10, 2016 10:30AM
You're right. It's not really a timeout. Putty just shows a blank screen.

I checked again with a brand new UART adapter, but it's exactly the same issue.The router is not communicating at all. The power led is on, that's it.
Re: Bricked MR3040
February 10, 2016 08:53PM
Ok, then I guess it is bricked :-( Sorry.
Re: Bricked MR3040
February 12, 2016 11:55AM
That's alright, thanks for trying to help me!
Re: Bricked MR3040
July 16, 2016 05:26PM
Well, after having flashed my mr3040 back to original firmware, then to openwrt, I decided to flash to original and then piratebox again. Everything seemed to go fine until piratebox setup. First, there was no /opt, so no Kareha or UPnP server. So I figured I'd start fresh with factory firmware. Somewhere along the line I screwed the pooch on this because now only the power led is on and nothing else.. Live and learn, right?
Re: Bricked MR3040
July 24, 2016 04:47PM
I am facing same problem. The LEDs are going on and off continuously. After I connect my TL MR3040v1 via serial port it is sending strange characters. No U Boot access. I have double checked the serial port settings. They are perfect. Can any one help me?
Re: Bricked MR3040
July 27, 2016 04:54PM
Sounds like you bricked the device with flashing back the original firmware.
Try to recover the device using ethernet cable and serial access. Then reflash using TFTP
Re: Bricked MR3040
July 27, 2016 04:55PM
> Aishik
and that sound like you broke your uboot... then it is bricked
Re: Bricked MR3040
August 07, 2016 08:51PM
Hi Matthias,

Almost a year ago i bricked my TP-Link TL MR3040. Do you still offer a debrick service? I live in the netherlands. What does it cost to restore the modem to its original firmware?
Re: Bricked MR3040
September 09, 2016 05:14PM
The mr3040 is touchy. I thought I bricked mine last night and worked on it for hours. I flashed it several times then I had to put it in failsafe mode....I even went as far as formatting the USB and saving the install files and .bin file on the stick as well. I was able to connect via ethernet but the wifi AP was not broadcasting and no /opt directory. So here is what I had to do.

-format USB and copy over files
-mount usb
-mv /mnt/usb/install/auto_package_done /mnt/usb/install/auto_package
-force re-write of firmware (it will reboot)

After this process it will reboot and and everything was good to go. I have built several of these boxes mostly raspberry pi's but mr3040 is my favorite but probably the trickiest out of all of them that I have done.
Re: Bricked MR3040
September 20, 2016 03:54PM
Usually, the installation on MR3040 or other OpenWrt based PirateBox is running quite smooth.. but SOMETIMES a bit flipps into the wrong direction and then the installation is hanging...
but usually you need only a few steps to overcome such a thing.. sometimes just a reflash. smiling smiley
Re: Bricked MR3040
January 19, 2017 03:27PM
I am afraid I bricked my MR3040, But I wonder if anyone has another thought. I made some changes trying to learn and now I can see the router in WiFi but cannot open in browser (time out message), will not respond to ping and can't open with putty (not accepted message).

“By seeking and blundering we learn.”
― Johann Wolfgang von Goethe
Re: Bricked MR3040
January 21, 2017 10:30AM
Did you try to recover it via failsave and USB stick?

best regards
Re: Bricked MR3040
February 15, 2017 09:19PM
Thanks took me a bit to get to it but worked.
Re: Bricked MR3040
November 04, 2017 10:21PM
So, I have an issue. When I turn it on I get the typical 1 light on 3 flashing. So I've been trying to get the serial connection for a while now with no luck nothing ever shows up in putty. I did do the loopback test with my USB-UART thingy, works fine. Anyway when connected correctly, as posted above, without the power switch on I get the power light on full and the wi-fi light on dimly. When I switch it on with it connected I just get the one on three flashing thing. Is this normal?
Re: Bricked MR3040
June 05, 2018 06:08PM
Hi Matthias,

I live in Holland and want to unbrick my TL-MR3040.
Can you help me out? Please send me an email to discuss further details!
Re: Bricked MR3040
July 06, 2018 03:55PM
did you give it a try yourself?

Are you sure it is really bricked? Have you tried the failsafe mode?

best regards Matthias