Piratebox auto installer trouble MR3020

Posted by ronjohnson 
This forum is currently read only. You can not log in or make any changes. This is a temporary situation.
Now, this forum is in read-only mode. You find details Details hereContinue on /r/PirateBox

I also have the same kernel panic that you comment previously when I try to install the customized OpenWrt firmware for my "TL-MR3020(UN) Ver:1.9".
If I install the non-customized firmware v15.05.1 downloaded from OpenWrt webpage, the router runs normally confused smiley

Could you tell me which version or where I could download it to install piratebox?

Thanks smiling smiley
Hello again,
I try to install manually the 1.1.4 version of piratebox on my TL-MR3020(UN) Ver.1.9, but again and again I got the same result:
[1.100000] VFS: Cannot open root device "(null)" or unknown-block(0,0)
[1.100000] Please append a correct "root=" boot option; here are the available partitions:
[1.110000] Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(0,0)

So I roll back to 1.1.3 version of piratebox link confused smiley. Maybe 1.1.4 version link of piratebox is not compatible with my device? Maybe there is an issue with the binary confused smiley
I hope that this information helps to another one with the same issue.
Re: Piratebox auto installer trouble MR3020
September 29, 2018 06:39PM
IF you have a 1.9UN make sure you got the correct MR3020 image file from stable.openwrt.piratebox.de

There should no difference between 1.1.3 and 1.1.4.
On 1.1.3 I replaced the the image with a -should be compatible- version:

[   ] openwrt-ar71xx-generic-tl-mr3020-v1-squashfs-factory.bin            27-Oct-2017 06:14  3.8M  
[   ] openwrt-ar71xx-generic-tl-mr3020-v1-squashfs-factory.bin.old        05-Oct-2016 20:09  3.8M  
[   ] openwrt-ar71xx-generic-tl-mr3020-v1-squashfs-factory.bin.sha256     27-Oct-2017 06:14  123   
[   ] openwrt-ar71xx-generic-tl-mr3020-v1-squashfs-factory.bin.sha256.old 05-Oct-2016 20:09  123

best regards Matthias
Thanks Matthias,

In the end I ended up installing version 1.1.3 of the repository and worked.

Thanks smiling smiley