Finally got piratebox working on TL-WR842N-V3

Posted by cannedtomatoes 
This forum is currently read only. You can not log in or make any changes. This is a temporary situation.
Now, this forum is in read-only mode. You find details Details hereContinue on /r/PirateBox
Finally got piratebox working on TL-WR842N-V3
June 01, 2018 11:39PM
Hi all,

I had a bit of trouble getting this up and running so I would like to document my experience here to help anyone else who runs into the same issues.

I got the TL-WR842N-V3 working with piratebox by following these steps:

1. Flash unit with the following firmware found on the openwrt site

2. Follow the following steps from the manual installation pages []

echo "src/gz piratebox []; >> /etc/opkg.conf
sed 's|option check_signature 1||g' -i /etc/opkg.conf
opkg update
opkg install extendRoot
/etc/init.d/ext init
source /etc/profile

The next steps didn't work for me so instead I used the piratebay install files []

I loaded the folder named 'cache' onto the usb and installed piratebox from the file
opkg install piratebox_1.1.0-4_all.ipk
This command prompted me to install the required files from the same folder and it all worked! There's probably a more straight forward process but this worked for me when I thought it might not happen. Hopefully this helps somebody.