PirateBox release 1.1.1

Posted by Matthias 
PirateBox release 1.1.1
October 03, 2016 02:13AM
Hello PirateBox-fellowers,

I am releasing that quick-fix release 1.1.1 now, because TheExpertNoob found out I did a mistake about building the 1.1.0 release, not the latest fixes were built into the release.

In addition I got feedback & fixes from ganastor, meaz and torx. Thank you alot for this!

The changelog reads out
Quote

* Quick release. 1.1.0 release was older then latest 1.1.0 development version
* [Fix] Translation en,fr LibraryBox → PirateBox
* [Fix] Spellings in translation
* [Fix] IRC startup command failed.
* [Removed] exchange_www.sh

Community, without out you, it would be much harder to get the project forward!

OpenWrt
As usually the upgrade instructions on [piratebox.cc] apply for this release also. Remember, that all changes in /opt/piratebox and OpenWrt changes will be overwritten.
This release contains fixes for the UI. In case you did not have a custom UI, you should consider to remove the folder "content" (in Piratebox) on your USB stick.

Technically, you can also do a "quick update", but only from 1.1.0:
* Download piratebox_ws_1.1_img.tar.gz
* Power off the PirateBox
* Take the USB stick to your computer
* Place piratebox_ws_1.1_img.tar.gz inside your install folder.
* Savely remove the USB stick and put it back to your PirateBox
* Power the PirateBox online
* Login via SSH to your PirateBox
* run the following commands:
  /etc/init.d/minidlna stop
  /etc/init.d/piratebox stop
  /etc/init.d/piratebox updatePB  
  /etc/init.d/piratebox start
  /etc/init.d/minidlna start

Upgrading in general has a bug
You will endup in a redirect loop in the browser. I will release 1.1.2 later today (2016-10-05).

To fix that you can do two things:
a) Power your PirateBox off and remove the folder "content" in the PirateBox directory. After that any custom modifications are gone and you get the new version of the UI. (prefered winking smiley
b) run the following command to link to your customized version of the content folder
 ln -s /opt/piratebox/share/content /opt/piratebox/www
I am sorry for that.

RaspberryPI
The recommended way for RPi is currently a complete reflash, like described in the RaspberryPi tutorial.

RaspberryPi 1 A, B & Zero
Language: PHP
magnet:?xt=urn:btih:e99c008f0496301cda76b267cd6a16915d389ec3&dn=piratebox_rpi_1.1.1-1-03-10-2016.img.zip&tr=udp%3A%2F%2Ftracker.piratebox.cc%3A7070&tr=udp%3A%2F%2Ftracker.coppersurfer.tk%3A6969

RaspberryPi 2 & 3
Language: PHP
magnet:?xt=urn:btih:0df637b67d7daaafafe5437435650580124d08c7&dn=piratebox_rpi2_1.1.1-1-03-10-2016.img.zip&tr=udp%3A%2F%2Ftracker.piratebox.cc%3A7070&tr=udp%3A%2F%2Ftracker.coppersurfer.tk%3A6969

Torrent files
If you encounter issues with the magnet links, please try to use the torrent files instead:
piratebox_rpi_1.1.1-1-03-10-2016.img.zip.torrent
piratebox_rpi2_1.1.1-1-03-10-2016.img.zip.torrent



best regards
Matthias
edit:
Added note about the quick update



Edited 5 time(s). Last edit at 10/05/2016 12:31AM by Matthias.
Re: PirateBox release 1.1.1
October 04, 2016 04:24PM
Not sure if anyone else has experienced this or not but using the "quick update" instructions resulted in a redirect loop when trying to access the landing page.
jcente
Re: PirateBox release 1.1.1
October 04, 2016 10:37PM
mine is not working, I never see the “PirateBox: Share freely” network.. :/
Re: PirateBox release 1.1.1
October 04, 2016 11:59PM
Thank you for playing around with PirateBox... I am sorry, that you encounter issues

@damavox:
Did you upgrade from 1.1.0 to 1.1.1 ? This is the only possible quick upgrade path.
This issues sounds to me more like a browser cache issue. I tested the 1.1.1 version with my RaspberryPi build (same base) and it worked without any issue.
edit: The RPi test is obviously only a clean reinstallation.
Ok, the issue is an upgrade issue in general. This will also appear if you upgrade from 1.1.0 to 1.1.1 without deleting the PirateBox folder. The content link is not regenerated. crap. I'll release 1.1.2 this evening.
To fix that issue, run:
 ln -s /opt/piratebox/share/content /opt/piratebox/www


@jcente:
Please open up a forum thread in OpenWrt, try to connect via ethernet cable and collect the information which are listed here [piratebox.cc]



Edited 1 time(s). Last edit at 10/05/2016 12:28AM by Matthias.
Re: PirateBox release 1.1.1
October 05, 2016 01:46AM
I upgraded to 1.1.0 but after demonstrating the PB to a friend on my Mr3020, when i unplugged it and plugged it back i ran into a DNS server failure. Sorry i didn't trouble shoot the issue. I put the PB in fail safe mode and ran a firstboot, then reinstalled 1.1.0 on OCT 2nd. then I attempted the 1.1.1 quick update today. I had cleared my browser's cache 4 hours prior to attemting the update but the chache still could have been the issue. I was headed out the door so i quickly repeated the previous steps i took via failsafe and first and put the install folder for 1.1.1 on my freshly formatted flash drive so that it would be ready when i came back home. Sorry i can't give you any kind of real information so that you couldf investigate further into the issue if need be.

Any chance the mesh feature will be added to the Rpi? I have quite alot of zeros laying around due to microcenter having them on sale for $0.99.
Re: PirateBox release 1.1.1
October 05, 2016 02:04AM
Damavox, I am pretty sure I found the issue and it is related to the new content directory. I am sorry, that you hit that bug... I never hit it during my tests. If you remove the content folder inside the PirateBox directory on the USB stick (and do a reboot afterwards), that will solve the issue.. even if you already have the problem.

Cool that you have bunch of Zeros. I have to solve different challenges to get the mesh feature up and running. Technically the script works, but there are some issues.

1st: you need two wifi cards per device. The shared usage between mesh and normal AP does not work on the most USB devices
2nd: the ArchLinux (which RPi image is based) kernel is newer then the OpenWrt image. This makes both batman protocolls incompatible with each other. So you have not a mesh cloud between all them.

The question is, what do you want to do with meshing zeros? Currently, the setup only creates a mesh wide IPv6 network. There is no additional functionality on top of it, neither there is the possibility to upload to a remote PirateBox.
jcente
Re: PirateBox release 1.1.1
October 05, 2016 01:14PM
@Matthias

The problem is that i'm trying to install it in a Raspberry Pi Zero, there is no ethernet port :/
Re: PirateBox release 1.1.1
October 05, 2016 01:31PM
Then please open up a thread in the RaspberryPi Forum and describe your setup with wifi adapter etc.

In addition, there should be an wpa_supplicant file in the FA32 part which should help you to connect your piratebox to your homenetwork in case of an adapter issue..

Matthias
Re: PirateBox release 1.1.1
October 05, 2016 01:33PM
I am closing this Post, because of the Release 1.1.2 thread.



Edited 1 time(s). Last edit at 10/05/2016 01:39PM by Matthias.
Sorry, you can't reply to this topic. It has been closed.