PirateBox release 1.1.4

Posted by Matthias 
This forum is currently read only. You can not log in or make any changes. This is a temporary situation.
Now, this forum is in read-only mode. You find details Details hereContinue on /r/PirateBox
PirateBox release 1.1.4
February 28, 2018 12:17AM
Hello PirateBox-fellowers,

Sorry, I wanted to avoid another 1.1.4 and push 1.2 out of the door.. but my freetime is so much restricted since September last year.. I decided to give 1.1.4 a chance ;-)
It is a pretty long list including lots of contributions. Work on 1.2 (or maybe a 2.0) is still going on- refer to our development subforum.

We also published our project goals in January.


[New] Removed legacy redirect.html, use /index.html only
[New] install_piratebox.sh, avoid distribution of index files, if turned off.
[New] mime.types: Adding gpx mime-type
[New] [i8n] Spanish and Basque
[New] [i8n] Russian translation
[New] [RPi] Add all needed things to create a simple on/off button
[Changed] [RPi] MotD generation reworked and more dynamically
[Changed] [RPi] Run timesave-save function during shutdown
[Changed] [RPi] Work with en_US.UTF-8 per default
[Fix] diskusage: Fix wrong error message
[Fix] lang-de ; fix grammar
[Fix] [RPi] Fix wrong path in wifi client helper script
[Fix] [RPi] Fix issue with diskusage generation & usb share
[Fix] [RPi] Enable cronie for startup, which was missing
[Fix] [RPi] Fixed resolv.conf. A default entry is now available
[Fix] [RPi] Fixed detection of 8188eu
[Fix] [RPi] Store the installed hostap package in /prebuild/hostapd
[Fix] initd: minircd startup fix setuid
[Fix] initd: minircd fixing start-stop issues
[Fix] initd: Fix radvd path to an absolute path
[Fix] initd: Ugly hack for absolute path of radvd on OpenWrt
[Fix] WWW-Content, fix a syntax error which broke jQuery
[Fix] Refresh kareha download URL, which changed in year 2015
[Fix] diskusage: Adding missing </head> tag
[Fix] timesave: Shellcheck issues fixed
[Fix] timesave: Problems with date & time format at RPi fixed

As usually the upgrade instructions on [piratebox.cc] apply for this release also. Remember, that all changes in /opt/piratebox and OpenWrt changes will be overwritten.
This release contains fixes for the UI. In case you did not have a custom UI, you should consider to remove the folder "content" (in Piratebox) on your USB stick.

Technically, you can also do a "quick update", but only from 1.1.x:
* Download piratebox_ws_1.1_img.tar.gz
* Power off the PirateBox
* Take the USB stick to your computer
* Place piratebox_ws_1.1_img.tar.gz inside your install folder.
* Savely remove the USB stick and put it back to your PirateBox
* Power the PirateBox online
* Login via SSH to your PirateBox
* run the following commands:
  /etc/init.d/minidlna stop
  /etc/init.d/piratebox stop
  /etc/init.d/piratebox updatePB  
  /etc/init.d/piratebox start
  /etc/init.d/minidlna start

The recommended way for RPi is currently a complete reflash, like described in the RaspberryPi tutorial.

RaspberryPi 1 A, B, Zero & Zero-w
Language: PHP

RaspberryPi 2 & 3
Language: PHP

Torrent files
If you encounter issues with the magnet links, please try to use the torrent files instead:

While the files are in place, and the torrents are already distributed- I am now starting to update piratebox.cc ... have fun. I hope everything is fine with that hotfix release.

Version 1.1.3 of the RPi image is still being shared by our root servers and the Openwrt files are available as well.. just in case it is needed.

best regards

removed placeholders, some notes & hints.

Edited 2 time(s). Last edit at 02/28/2018 12:38AM by Matthias.
Re: PirateBox release 1.1.4
February 28, 2018 08:15PM
This is great, I will try to seed as much as possible. my upload is horrid, unfortunately...

I have a question, though. When reflashing on the SD card should I format the sd card before I use etcher to flash another piratebox image? When I flashed 1.1.3 for RPi3 on the same SD card a second time and started the install process in ssh, it said some red text stating something about ext4 and ext3 (I believe those are the numbers...) already existing. Sorry I didn't save the log of it doing that.

Thank you again.
Re: PirateBox release 1.1.4
February 28, 2018 08:42PM
Ah, maybe the SDCard share script is stumbling over something in some cases. Mh!
Doing a proper format is always an option, but you can try to run into the same error as before and we can try to fix that bug/issue in the corrsponding script winking smiley

Best regards Matthias
Re: PirateBox release 1.1.4
March 01, 2018 04:34AM
Hi there,

I'm having problems upgrading from 1.1.3 to 1.1.4 on my GL.iNet GL-AR150 Piratebox.

Here is what I did:

1. Create auto_flash folder on USB Stick and place the newest (20-Feb-2018) openwrt-ar71xx-generic-gl-ar150-squashfs-sysupgrade.bin inside.
2. Delete the old install folder from USB Stick & replace it with the install folder from the newest (27-Feb-2018) install_piratebox.zip .
3. Delete content folder from USB Stick in Piratebox folder.
4. Plug USB Stick back into router & start it up.
5. Wait until it stops rebooting.

Now, when I run cat /opt/piratebox/version it still says 1.1.3, so I guess something went wrong.

Here is the log from after my upgrade attempt:

And before my upgrade attempt:

Did I do something wrong?
Thanks in advance!
Re: PirateBox release 1.1.4
March 01, 2018 04:10PM
that totally looks like the firmware flash did not work properly. Unfortunately it is not possible to story the error log of the responsible script.
The install log says, that all packages are already installed.

You have three options:
a) We debug this issue with a bunch of manual steps, and find out the root cause
b) You chose to make the short update with "/etc/init.d/piratebox updatePB"
c) You do a manual reflash like this [piratebox.cc]

let me know (or better in case of a, open a new topic under the openwrt subforum)

best regards Matthias
Re: PirateBox release 1.1.4
March 26, 2018 03:31AM
IRC server works just perfect!!!

Cheers from Argentina

Re: PirateBox release 1.1.4
March 26, 2018 11:18AM
Thanks Matthias

Keep up the good work
Re: PirateBox release 1.1.4
June 12, 2018 02:52PM
After i made my SD Card like written in the Rspi 3 Tutorial i have some Problems:

When i call up my web via MYIP/board i will receive the board, with MYIP/content the screen will be white.
After use the board and i will back "home" it goes directly to "piraebox.lan/content and i receive an 403 Error.....

What i made wrong ?
How can i resolve this ?

Please help.
Re: PirateBox release 1.1.4
July 06, 2018 05:47PM
Problems with the board are usually closely connected with using special Characters in the administrator password.

Have a look at /opt/piratebox/share/board/config.pl , the entry you are looking for is "ADMIN_PASS"
Re: PirateBox release 1.1.4
May 17, 2019 08:54AM
Hey how can I change the website in this version?