NEW OPEN WRT SUPPORT FOR TP-Link TL-MR10U smiling bouncing smiley

Posted by jmac928 
NEW OPEN WRT SUPPORT FOR TP-Link TL-MR10U smiling bouncing smiley
June 16, 2013 09:38PM
TP-Link TL-MR10U ---(WIKI)--- smiling bouncing smiley



Edited 1 time(s). Last edit at 06/16/2013 09:38PM by jmac928.
Re: NEW OPEN WRT SUPPORT FOR TP-Link TL-MR10U smiling bouncing smiley
June 18, 2013 01:22AM
Thanks for the tip. I ordered one. I'll let everyone know if/when I get PB running on it. grinning smiley



Edited 1 time(s). Last edit at 06/18/2013 01:22AM by angrygnome.
Re: NEW OPEN WRT SUPPORT FOR TP-Link TL-MR10U smiling bouncing smiley
June 21, 2013 07:23AM
Hey guys.

jmac contacted me to create custom images for that.

I did this this morning:

[stable.openwrt.piratebox.de]

This are images from the trunk source, so read carefully my README.txt before using it.

Because I don't have time neither a device, I wasn't able test it.

regards Matthias
---
PS: I'm not a fan of that trunk stuff and this took me 3 hours of my life to get my makefiles working on trunk image, because they changed a few things.
PPS: If I supported an onlineshop with doing that support, I appreciate BTC/amazon donations winking smiley


I'm sorry for long response times, it is still my free time project.
About Matthias ; Flattr
Re: NEW OPEN WRT SUPPORT FOR TP-Link TL-MR10U smiling bouncing smiley
June 21, 2013 01:14PM
Thanks Matthias!

I was able to get PB working on the TL-MR10U before you put this up. I manually installed the kernel modules, etc. (Works great.) I'm installing PHP and configuring it now. I'll update with more details when I get home tonight.
Re: NEW OPEN WRT SUPPORT FOR TP-Link TL-MR10U smiling bouncing smiley
June 21, 2013 01:15PM
Hi,
yeah trunk image may work totally fine.
The issue only comes up if shit hits the fan and the kernel-packages are not in the same line like the firmware files. This issue was quite common these days when we started with PBx.

Matthias
Re: NEW OPEN WRT SUPPORT FOR TP-Link TL-MR10U smiling bouncing smiley
June 21, 2013 04:06PM
Thank you Very Much Matthias for your work
In the link [stable.openwrt.piratebox.de] there is no image with mr10u name ......
Re: NEW OPEN WRT SUPPORT FOR TP-Link TL-MR10U smiling bouncing smiley
June 22, 2013 12:10AM
Here's a pic with the MR10U and the MR3020 for comparison. Performance seems about the same for both (which makes sense since they have similar hardware). It's awesome having a battery built in. You don't even need something to put it in... just throw it in a pocket. grinning smiley



I bought mine here:

TinyDeal

Shipping is free but I selected DHL express for $12 and it got to me in 2 days from China to the US!
Re: NEW OPEN WRT SUPPORT FOR TP-Link TL-MR10U smiling bouncing smiley
June 22, 2013 04:10AM
Hello Angrygnome
Would you please post the image of openwrt that you builded for it ...
Thanks a lot..
Re: NEW OPEN WRT SUPPORT FOR TP-Link TL-MR10U smiling bouncing smiley
June 22, 2013 04:20AM
I did not build an image for it. I used the firmware you linked to in your original post and then followed the OpenWRT PB DIY instructions here:

[daviddarts.com]

Make sure to install the kernel modules described in step 15.

It's not hard to do if you follow the instructions.
Re: NEW OPEN WRT SUPPORT FOR TP-Link TL-MR10U smiling bouncing smiley
June 22, 2013 08:20AM
jmac928 Wrote:
-------------------------------------------------------
> Thank you Very Much Matthias for your work
> In the link
> [stable.openwrt.piratebox.de] there is
> no image with mr10u name ......


Sure there is one, only the name is shortend: [stable.openwrt.piratebox.de]
(can't influence the index-list from webserver on shared hosting)
Re: NEW OPEN WRT SUPPORT FOR TP-Link TL-MR10U smiling bouncing smiley
June 23, 2013 03:14AM
The instalation Stop .. the message say


root@OpenWrt:/tmp# opkg update && opkg install [piratebox.aod-rpg.de]
ebox_0.6.3_all.ipk
Downloading [downloads.openwrt.org].
Updated list of available packages in /var/opkg-lists/barrier_breaker.
Downloading [stable.openwrt.piratebox.de].
Updated list of available packages in /var/opkg-lists/piratebox.
Downloading [piratebox.aod-rpg.de].
Installing piratebox (0.6.3) to root...
Configuring piratebox.
Please connect USB disk. If it is already plugged-in,
wait for a few seconds, and if nothing happens, please
reconnect the device. Keep in mind that your router's
ports may not be able to supply enough power to
spin-up a USB HDD.
...............................................................................................


Here stop the instalation process an stay ....................................... forever

i searched this problem and i found [forum.daviddarts.com]

then i follow your instructions

#dmesg

#lsmod

root@OpenWrt:~# dmesg
[ 0.000000] Linux version 3.8.13 (openwrt@snapon) (gcc version 4.6.4 (OpenWrt/Linaro GCC 4.6-2012.12 r36969) ) #1 Wed Jun 19 22:33:15 PDT 2013
[ 0.000000] MyLoader: sysp=fa89c804, boardp=69cd3b24, parts=31a09c82
[ 0.000000] bootconsole [early0] enabled
[ 0.000000] CPU revision is: 00019374 (MIPS 24Kc)
[ 0.000000] SoC: Atheros AR9330 rev 1
[ 0.000000] Clocks: CPU:400.000MHz, DDR:400.000MHz, AHB:200.000MHz, Ref:25.000MHz
[ 0.000000] Determined physical RAM map:
[ 0.000000] memory: 02000000 @ 00000000 (usable)
[ 0.000000] Initrd not found or empty - disabling initrd
[ 0.000000] Zone ranges:
[ 0.000000] Normal [mem 0x00000000-0x01ffffff]
[ 0.000000] Movable zone start for each node
[ 0.000000] Early memory node ranges
[ 0.000000] node 0: [mem 0x00000000-0x01ffffff]
[ 0.000000] On node 0 totalpages: 8192
[ 0.000000] free_area_init_node: node 0, pgdat 80320a40, node_mem_map 81000000
[ 0.000000] Normal zone: 64 pages used for memmap
[ 0.000000] Normal zone: 0 pages reserved
[ 0.000000] Normal zone: 8128 pages, LIFO batch:0
[ 0.000000] Primary instruction cache 64kB, VIPT, 4-way, linesize 32 bytes.
[ 0.000000] Primary data cache 32kB, 4-way, VIPT, cache aliases, linesize 32 bytes
[ 0.000000] pcpu-alloc: s0 r0 d32768 u32768 alloc=1*32768
[ 0.000000] pcpu-alloc: [0] 0
[ 0.000000] Built 1 zonelists in Zone order, mobility grouping on. Total pages: 8128
[ 0.000000] Kernel command line: board=TL-MR11U console=ttyATH0,115200 rootfstype=squashfs,jffs2 noinitrd
[ 0.000000] PID hash table entries: 128 (order: -3, 512 bytes)
[ 0.000000] Dentry cache hash table entries: 4096 (order: 2, 16384 bytes)
[ 0.000000] Inode-cache hash table entries: 2048 (order: 1, 8192 bytes)
[ 0.000000] __ex_table already sorted, skipping sort
[ 0.000000] Writing ErrCtl register=00000000
[ 0.000000] Readback ErrCtl register=00000000
[ 0.000000] Memory: 28720k/32768k available (2306k kernel code, 4048k reserved, 599k data, 228k init, 0k highmem)
[ 0.000000] SLUB: Genslabs=9, HWalign=32, Order=0-3, MinObjects=0, CPUs=1, Nodes=1
[ 0.000000] NR_IRQS:51
[ 0.080000] Calibrating delay loop... 265.42 BogoMIPS (lpj=1327104)
[ 0.080000] pid_max: default: 32768 minimum: 301
[ 0.080000] Mount-cache hash table entries: 512
[ 0.090000] NET: Registered protocol family 16
[ 0.090000] MIPS: machine is TP-LINK TL-MR11U
[ 0.350000] bio: create slab <bio-0> at 0
[ 0.350000] Switching to clocksource MIPS
[ 0.360000] NET: Registered protocol family 2
[ 0.360000] TCP established hash table entries: 512 (order: 0, 4096 bytes)
[ 0.370000] TCP bind hash table entries: 512 (order: -1, 2048 bytes)
[ 0.370000] TCP: Hash tables configured (established 512 bind 512)
[ 0.380000] TCP: reno registered
[ 0.380000] UDP hash table entries: 256 (order: 0, 4096 bytes)
[ 0.390000] UDP-Lite hash table entries: 256 (order: 0, 4096 bytes)
[ 0.400000] NET: Registered protocol family 1
[ 0.400000] PCI: CLS 0 bytes, default 32
[ 0.420000] squashfs: version 4.0 (2009/01/31) Phillip Lougher
[ 0.420000] jffs2: version 2.2 (NAND) (SUMMARY) (LZMA) (RTIME) (CMODE_PRIORITY) (c) 2001-2006 Red Hat, Inc.
[ 0.430000] msgmni has been set to 56
[ 0.440000] Block layer SCSI generic (bsg) driver version 0.4 loaded (major 253)
[ 0.440000] io scheduler noop registered
[ 0.450000] io scheduler deadline registered (default)
[ 0.450000] Serial: 8250/16550 driver, 16 ports, IRQ sharing enabled
[ 0.460000] ar933x-uart: ttyATH0 at MMIO 0x18020000 (irq = 11) is a AR933X UART
[ 0.470000] console [ttyATH0] enabled, bootconsole disabled
[ 0.480000] ath79-spi ath79-spi: master is unqueued, this is deprecated
[ 0.490000] m25p80 spi0.0: found en25q32b, expected m25p80
[ 0.490000] m25p80 spi0.0: en25q32b (4096 Kbytes)
[ 0.500000] 5 tp-link partitions found on MTD device spi0.0
[ 0.500000] Creating 5 MTD partitions on "spi0.0":
[ 0.510000] 0x000000000000-0x000000020000 : "u-boot"
[ 0.520000] 0x000000020000-0x0000001228a4 : "kernel"
[ 0.520000] mtd: partition "kernel" must either start or end on erase block boundary or be smaller than an erase block -- forcing read-only
[ 0.530000] 0x0000001228a4-0x0000003f0000 : "rootfs"
[ 0.540000] mtd: partition "rootfs" must either start or end on erase block boundary or be smaller than an erase block -- forcing read-only
[ 0.550000] mtd: partition "rootfs" set to be root filesystem
[ 0.560000] mtd: partition "rootfs_data" created automatically, ofs=330000, len=C0000
[ 0.560000] 0x000000330000-0x0000003f0000 : "rootfs_data"
[ 0.570000] 0x0000003f0000-0x000000400000 : "art"
[ 0.580000] 0x000000020000-0x0000003f0000 : "firmware"
[ 0.600000] libphy: ag71xx_mdio: probed
[ 0.600000] eth0: Atheros AG71xx at 0xb9000000, irq 4, mode:MII
[ 1.150000] ag71xx ag71xx.0 eth0: connected to PHY at ag71xx-mdio.1:04 [uid=004dd041, driver=Generic PHY]
[ 1.160000] TCP: cubic registered
[ 1.160000] NET: Registered protocol family 17
[ 1.170000] Bridge firewalling registered
[ 1.170000] 8021q: 802.1Q VLAN Support v1.8
[ 1.180000] VFS: Mounted root (squashfs filesystem) readonly on device 31:2.
[ 1.190000] Freeing unused kernel memory: 228k freed
[ 6.150000] eth0: link up (100Mbps/Full duplex)
[ 7.130000] jffs2: notice: (457) jffs2_build_xattr_subsystem: complete building xattr subsystem, 1 of xdatum (0 unchecked, 0 orphan) and 12 of xref (0 dead, 2 orphan) found.
[ 7.740000] SCSI subsystem initialized
[ 7.880000] usbcore: registered new interface driver usbfs
[ 7.890000] usbcore: registered new interface driver hub
[ 7.890000] usbcore: registered new device driver usb
[ 8.510000] ehci_hcd: USB 2.0 'Enhanced' Host Controller (EHCI) Driver
[ 8.520000] ehci-platform: EHCI generic platform driver
[ 8.530000] ehci-platform ehci-platform: EHCI Host Controller
[ 8.530000] ehci-platform ehci-platform: new USB bus registered, assigned bus number 1
[ 8.540000] ehci-platform ehci-platform: irq 3, io mem 0x1b000000
[ 8.570000] ehci-platform ehci-platform: USB 2.0 started, EHCI 1.00
[ 8.570000] hub 1-0:1.0: USB hub found
[ 8.570000] hub 1-0:1.0: 1 port detected
[ 8.620000] Initializing USB Mass Storage driver...
[ 8.620000] usbcore: registered new interface driver usb-storage
[ 8.630000] USB Mass Storage support registered.
[ 28.970000] eth0: link down
[ 29.700000] Loading modules backported from Linux version master-2013-06-13-0-g09fcdfb
[ 29.700000] Backport generated by backports.git backports-20130531-13-g3d933eb
[ 29.740000] cfg80211: Calling CRDA to update world regulatory domain
[ 29.750000] cfg80211: World regulatory domain updated:
[ 29.750000] cfg80211: (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
[ 29.760000] cfg80211: (2402000 KHz - 2472000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[ 29.770000] cfg80211: (2457000 KHz - 2482000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
[ 29.780000] cfg80211: (2474000 KHz - 2494000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
[ 29.780000] cfg80211: (5170000 KHz - 5250000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[ 29.790000] cfg80211: (5735000 KHz - 5835000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[ 30.090000] NET: Registered protocol family 10
[ 30.960000] ath: EEPROM regdomain: 0x0
[ 30.960000] ath: EEPROM indicates default country code should be used
[ 30.960000] ath: doing EEPROM country->regdmn map search
[ 30.960000] ath: country maps to regdmn code: 0x3a
[ 30.960000] ath: Country alpha2 being used: US
[ 30.960000] ath: Regpair used: 0x3a
[ 30.970000] ieee80211 phy0: Selected rate control algorithm 'minstrel_ht'
[ 30.970000] ieee80211 phy0: Atheros AR9330 Rev:1 mem=0xb8100000, irq=2
[ 30.980000] cfg80211: Calling CRDA for country: US
[ 30.980000] cfg80211: Regulatory domain changed to country: US
[ 30.990000] cfg80211: (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
[ 31.000000] cfg80211: (2402000 KHz - 2472000 KHz @ 40000 KHz), (300 mBi, 2700 mBm)
[ 31.000000] cfg80211: (5170000 KHz - 5250000 KHz @ 40000 KHz), (300 mBi, 1700 mBm)
[ 31.010000] cfg80211: (5250000 KHz - 5330000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[ 31.020000] cfg80211: (5490000 KHz - 5600000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[ 31.030000] cfg80211: (5650000 KHz - 5710000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[ 31.040000] cfg80211: (5735000 KHz - 5835000 KHz @ 40000 KHz), (300 mBi, 3000 mBm)
[ 31.480000] loop: module loaded
[ 31.540000] ip_tables: (C) 2000-2006 Netfilter Core Team
[ 31.680000] xt_time: kernel timezone is -0000
[ 31.770000] nf_conntrack version 0.5.0 (452 buckets, 1808 max)
[ 32.040000] ip6_tables: (C) 2000-2006 Netfilter Core Team
[ 32.290000] batman_adv: B.A.T.M.A.N. advanced 2013.2.0 (compatibility version 14) loaded
[ 37.030000] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready
[ 37.040000] device eth0 entered promiscuous mode
[ 37.040000] IPv6: ADDRCONF(NETDEV_UP): br-lan: link is not ready
[ 37.400000] eth0: link up (100Mbps/Full duplex)
[ 37.400000] br-lan: port 1(eth0) entered forwarding state
[ 37.410000] br-lan: port 1(eth0) entered forwarding state
[ 37.410000] IPv6: ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
[ 37.420000] IPv6: ADDRCONF(NETDEV_CHANGE): br-lan: link becomes ready
[ 39.410000] br-lan: port 1(eth0) entered forwarding state
[ 287.950000] uhci_hcd: USB Universal Host Controller Interface driver
[ 325.760000] ohci_hcd: USB 1.1 'Open' Host Controller (OHCI) Driver

root@OpenWrt:~# lsmod
Module Size Used by Tainted: G
ohci_hcd 16544 0
uhci_hcd 18336 0
ath79_wdt 2656 1
ledtrig_usbdev 1936 0
ledtrig_netdev 3104 0
batman_adv 103458 0
ip6t_REJECT 2416 2
ip6t_rt 1584 0
ip6t_hbh 1296 0
ip6t_mh 704 0
ip6t_ipv6header 1072 0
ip6t_frag 880 0
ip6t_eui64 704 0
ip6t_ah 816 0
ip6table_raw 576 1
ip6table_mangle 944 1
ip6table_filter 608 1
ip6_tables 8993 3 ip6table_raw,ip6table_mangle,ip6table_filter
nf_conntrack_ipv6 5856 3
nf_defrag_ipv6 4865 1 nf_conntrack_ipv6
nf_nat_irc 848 0
nf_nat_ftp 1120 0
nf_conntrack_irc 2704 1 nf_nat_irc
nf_conntrack_ftp 4912 1 nf_nat_ftp
xt_REDIRECT 1040 0
ipt_MASQUERADE 1104 1
iptable_nat 1920 1
xt_nat 1088 0
nf_nat_ipv4 2686 1 iptable_nat
nf_nat 10512 7 nf_nat_irc,nf_nat_ftp,xt_REDIRECT,ipt_MASQUERADE,iptable_nat,xt_nat,nf_nat_ipv4
xt_conntrack 2176 6
xt_CT 2416 0
iptable_raw 640 1
xt_state 688 0
nf_conntrack_ipv4 5108 4
nf_defrag_ipv4 758 1 nf_conntrack_ipv4
nf_conntrack 43940 13 nf_conntrack_ipv6,nf_nat_irc,nf_nat_ftp,nf_conntrack_irc,nf_conntrack_ftp,ipt_MASQUERADE,iptable_nat,nf_nat_ipv4,nf_nat,xt_conntrack,xt_CT,xt_state,nf_conntrack_ipv4
xt_mark 672 0
xt_time 1664 0
ipt_REJECT 1808 2
xt_TCPMSS 2624 0
xt_LOG 9488 0
xt_comment 480 47
xt_multiport 1184 0
xt_mac 608 0
xt_limit 1008 20
iptable_mangle 912 1
iptable_filter 672 1
ip_tables 9117 4 iptable_nat,iptable_raw,iptable_mangle,iptable_filter
xt_tcpudp 1680 6
x_tables 10997 32 ip6t_REJECT,ip6t_rt,ip6t_hbh,ip6t_mh,ip6t_ipv6header,ip6t_frag,ip6t_eui64,ip6t_ah,ip6table_raw,ip6table_mangle,ip6table_filter,ip6_tables,xt_REDIRECT,ipt_MASQUERADE,xt_nat,xt_conntrack,xt_CT,iptable_raw,xt_state,xt_mark,xt_time,ipt_REJECT,xt_TCPMSS,xt_LOG,xt_comment,xt_multiport,xt_mac,xt_limit,iptable_mangle,iptable_filter,ip_tables,xt_tcpudp
loop 11328 0
vfat 7904 0
fat 43247 1 vfat
ath9k 94192 0
ath9k_common 1624 1 ath9k
ath9k_hw 355518 2 ath9k,ath9k_common
ath 15177 3 ath9k,ath9k_common,ath9k_hw
nls_utf8 864 0
nls_iso8859_15 3392 0
nls_iso8859_1 2880 0
nls_cp850 3648 0
nls_cp437 4416 0
mac80211 308776 1 ath9k
ipv6 244736 26 ip6t_REJECT,ip6table_mangle,nf_conntrack_ipv6,nf_defrag_ipv6
cfg80211 170753 3 ath9k,ath,mac80211
compat 1774 5 ath9k,ath9k_common,ath9k_hw,mac80211,cfg80211
arc4 1312 2
crypto_blkcipher 10327 1 arc4
aead 4256 0
usb_storage 36072 0
ehci_platform 1776 0
ehci_hcd 30204 1 ehci_platform
sd_mod 24448 0
ext4 284956 0
jbd2 46172 1 ext4
mbcache 3997 1 ext4
usbcore 106313 6 ohci_hcd,uhci_hcd,ledtrig_usbdev,usb_storage,ehci_platform,ehci_hcd
usb_common 562 1 usbcore
scsi_mod 76555 2 usb_storage,sd_mod
nls_base 4974 8 vfat,fat,nls_utf8,nls_iso8859_15,nls_iso8859_1,nls_cp850,nls_cp437,usbcore
libcrc32c 583 1 batman_adv
crc16 1015 2 batman_adv,ext4
crc32c 976 1
crypto_hash 9546 4 ext4,jbd2,libcrc32c,crc32c
ledtrig_timer 1072 0
ledtrig_default_on 496 0
leds_gpio 1600 0
gpio_button_hotplug 3504 0


My flash drive is new kingston 8gb
I tried with other flash drives but continues
showing this message

Please connect USB disk. If it is already plugged-in,
wait for a few seconds, and if nothing happens, please
reconnect the device. Keep in mind that your router's
ports may not be able to supply enough power to
spin-up a USB HDD.
...............................................................................................

Any idea ....
Re: NEW OPEN WRT SUPPORT FOR TP-Link TL-MR10U smiling bouncing smiley
June 23, 2013 08:47AM
first of all you need to remove the package first: [piratebox.aod-rpg.de]

Then I need the dmesg output before you installl the package. Simply put into the usb stick and then run dmesg and post the output.

The Firmware contains (only) exact the same packages like piratebox-package needs during install. You can confirm this argument on the output above, because before installing piratebox, there are no additional packages installed.

Which exact usb stick do you have?- link?

regards Matthias
Re: NEW OPEN WRT SUPPORT FOR TP-Link TL-MR10U smiling bouncing smiley
June 23, 2013 04:13PM
root@OpenWRT:/tmp# opkg remove piratebox
Removing package piratebox from root...
/etc/rc.common: line 116: /opt/piratebox/init.d/piratebox_router: not found
Resetting OpenWRT config to factory state...
uci: Entry not found
uci: Entry not found
uci: Entry not found
uci: Entry not found
uci: Entry not found
cp: '/rom/etc/opkg.conf' and '/etc/opkg.conf' are the same file
cp: '/rom/etc/hosts' and '/etc/hosts' are the same file
cp: '/rom/etc/init.d/dnsmasq' and '/etc/init.d/dnsmasq' are the same file
rm: can't remove '/usr/local': No such file or directory
Please reboot for changes to take effect.
root@OpenWRT:/tmp# reboot
root@OpenWRT:/tmp#
login as: root
login as: root
root@192.168.1.1's password:


BusyBox v1.19.4 (2013-06-19 14:12:20 PDT) built-in shell (ash)
Enter 'help' for a list of built-in commands.

_______ ________ __
| |.-----.-----.-----.| | | |.----.| |_
| - || _ | -__| || | | || _|| _|
|_______|| __|_____|__|__||________||__| |____|
|__| W I R E L E S S F R E E D O M
-----------------------------------------------------
BARRIER BREAKER (Bleeding Edge, r36969)
-----------------------------------------------------
* 1/2 oz Galliano Pour all ingredients into
* 4 oz cold Coffee an irish coffee mug filled
* 1 1/2 oz Dark Rum with crushed ice. Stir.
* 2 tsp. Creme de Cacao
-----------------------------------------------------
root@OpenWRT:~# dmesg
[ 0.000000] Linux version 3.8.13 (openwrt@snapon) (gcc version 4.6.4 (OpenWrt /Linaro GCC 4.6-2012.12 r36969) ) #1 Wed Jun 19 22:33:15 PDT 2013
[ 0.000000] MyLoader: sysp=fa89c804, boardp=69cd3b24, parts=31a09c82
[ 0.000000] bootconsole [early0] enabled
[ 0.000000] CPU revision is: 00019374 (MIPS 24Kc)
[ 0.000000] SoC: Atheros AR9330 rev 1
[ 0.000000] Clocks: CPU:400.000MHz, DDR:400.000MHz, AHB:200.000MHz, Ref:25.00 0MHz
[ 0.000000] Determined physical RAM map:
[ 0.000000] memory: 02000000 @ 00000000 (usable)
[ 0.000000] Initrd not found or empty - disabling initrd
[ 0.000000] Zone ranges:
[ 0.000000] Normal [mem 0x00000000-0x01ffffff]
[ 0.000000] Movable zone start for each node
[ 0.000000] Early memory node ranges
[ 0.000000] node 0: [mem 0x00000000-0x01ffffff]
[ 0.000000] On node 0 totalpages: 8192
[ 0.000000] free_area_init_node: node 0, pgdat 80320a40, node_mem_map 8100000 0
[ 0.000000] Normal zone: 64 pages used for memmap
[ 0.000000] Normal zone: 0 pages reserved
[ 0.000000] Normal zone: 8128 pages, LIFO batch:0
[ 0.000000] Primary instruction cache 64kB, VIPT, 4-way, linesize 32 bytes.
[ 0.000000] Primary data cache 32kB, 4-way, VIPT, cache aliases, linesize 32 bytes
[ 0.000000] pcpu-alloc: s0 r0 d32768 u32768 alloc=1*32768
[ 0.000000] pcpu-alloc: [0] 0
[ 0.000000] Built 1 zonelists in Zone order, mobility grouping on. Total pag es: 8128
[ 0.000000] Kernel command line: board=TL-MR11U console=ttyATH0,115200 rootf stype=squashfs,jffs2 noinitrd
[ 0.000000] PID hash table entries: 128 (order: -3, 512 bytes)
[ 0.000000] Dentry cache hash table entries: 4096 (order: 2, 16384 bytes)
[ 0.000000] Inode-cache hash table entries: 2048 (order: 1, 8192 bytes)
[ 0.000000] __ex_table already sorted, skipping sort
[ 0.000000] Writing ErrCtl register=00000000
[ 0.000000] Readback ErrCtl register=00000000
[ 0.000000] Memory: 28720k/32768k available (2306k kernel code, 4048k reserve d, 599k data, 228k init, 0k highmem)
[ 0.000000] SLUB: Genslabs=9, HWalign=32, Order=0-3, MinObjects=0, CPUs=1, No des=1
[ 0.000000] NR_IRQS:51
[ 0.080000] Calibrating delay loop... 265.42 BogoMIPS (lpj=1327104)
[ 0.080000] pid_max: default: 32768 minimum: 301
[ 0.080000] Mount-cache hash table entries: 512
[ 0.090000] NET: Registered protocol family 16
[ 0.090000] MIPS: machine is TP-LINK TL-MR11U
[ 0.350000] bio: create slab <bio-0> at 0
[ 0.350000] Switching to clocksource MIPS
[ 0.360000] NET: Registered protocol family 2
[ 0.360000] TCP established hash table entries: 512 (order: 0, 4096 bytes)
[ 0.370000] TCP bind hash table entries: 512 (order: -1, 2048 bytes)
[ 0.370000] TCP: Hash tables configured (established 512 bind 512)
[ 0.380000] TCP: reno registered
[ 0.380000] UDP hash table entries: 256 (order: 0, 4096 bytes)
[ 0.390000] UDP-Lite hash table entries: 256 (order: 0, 4096 bytes)
[ 0.400000] NET: Registered protocol family 1
[ 0.400000] PCI: CLS 0 bytes, default 32
[ 0.420000] squashfs: version 4.0 (2009/01/31) Phillip Lougher
[ 0.420000] jffs2: version 2.2 (NAND) (SUMMARY) (LZMA) (RTIME) (CMODE_PRIORIT Y) (c) 2001-2006 Red Hat, Inc.
[ 0.430000] msgmni has been set to 56
[ 0.440000] Block layer SCSI generic (bsg) driver version 0.4 loaded (major 2 53)
[ 0.440000] io scheduler noop registered
[ 0.450000] io scheduler deadline registered (default)
[ 0.450000] Serial: 8250/16550 driver, 16 ports, IRQ sharing enabled
[ 0.460000] ar933x-uart: ttyATH0 at MMIO 0x18020000 (irq = 11) is a AR933X UA RT
[ 0.470000] console [ttyATH0] enabled, bootconsole disabled
[ 0.480000] ath79-spi ath79-spi: master is unqueued, this is deprecated
[ 0.490000] m25p80 spi0.0: found en25q32b, expected m25p80
[ 0.490000] m25p80 spi0.0: en25q32b (4096 Kbytes)
[ 0.500000] 5 tp-link partitions found on MTD device spi0.0
[ 0.500000] Creating 5 MTD partitions on "spi0.0":
[ 0.510000] 0x000000000000-0x000000020000 : "u-boot"
[ 0.520000] 0x000000020000-0x0000001228a4 : "kernel"
[ 0.520000] mtd: partition "kernel" must either start or end on erase block b oundary or be smaller than an erase block -- forcing read-only
[ 0.530000] 0x0000001228a4-0x0000003f0000 : "rootfs"
[ 0.540000] mtd: partition "rootfs" must either start or end on erase block b oundary or be smaller than an erase block -- forcing read-only
[ 0.550000] mtd: partition "rootfs" set to be root filesystem
[ 0.560000] mtd: partition "rootfs_data" created automatically, ofs=330000, l en=C0000
[ 0.560000] 0x000000330000-0x0000003f0000 : "rootfs_data"
[ 0.570000] 0x0000003f0000-0x000000400000 : "art"
[ 0.580000] 0x000000020000-0x0000003f0000 : "firmware"
[ 0.600000] libphy: ag71xx_mdio: probed
[ 0.600000] eth0: Atheros AG71xx at 0xb9000000, irq 4, mode:MII
[ 1.150000] ag71xx ag71xx.0 eth0: connected to PHY at ag71xx-mdio.1:04 [uid=0 04dd041, driver=Generic PHY]
[ 1.160000] TCP: cubic registered
[ 1.160000] NET: Registered protocol family 17
[ 1.170000] Bridge firewalling registered
[ 1.170000] 8021q: 802.1Q VLAN Support v1.8
[ 1.180000] VFS: Mounted root (squashfs filesystem) readonly on device 31:2.
[ 1.190000] Freeing unused kernel memory: 228k freed
[ 6.150000] eth0: link up (100Mbps/Full duplex)
[ 7.130000] jffs2: notice: (457) jffs2_build_xattr_subsystem: complete buildi ng xattr subsystem, 1 of xdatum (1 unchecked, 0 orphan) and 12 of xref (0 dead, 2 orphan) found.
[ 7.750000] SCSI subsystem initialized
[ 7.890000] usbcore: registered new interface driver usbfs
[ 7.900000] usbcore: registered new interface driver hub
[ 7.910000] usbcore: registered new device driver usb
[ 8.520000] ehci_hcd: USB 2.0 'Enhanced' Host Controller (EHCI) Driver
[ 8.540000] ehci-platform: EHCI generic platform driver
[ 8.540000] ehci-platform ehci-platform: EHCI Host Controller
[ 8.550000] ehci-platform ehci-platform: new USB bus registered, assigned bus number 1
[ 8.550000] ehci-platform ehci-platform: irq 3, io mem 0x1b000000
[ 8.580000] ehci-platform ehci-platform: USB 2.0 started, EHCI 1.00
[ 8.580000] hub 1-0:1.0: USB hub found
[ 8.580000] hub 1-0:1.0: 1 port detected
[ 8.640000] ohci_hcd: USB 1.1 'Open' Host Controller (OHCI) Driver
[ 8.680000] uhci_hcd: USB Universal Host Controller Interface driver
[ 8.710000] Initializing USB Mass Storage driver...
[ 8.710000] usbcore: registered new interface driver usb-storage
[ 8.720000] USB Mass Storage support registered.
[ 29.070000] eth0: link down
[ 29.790000] Loading modules backported from Linux version master-2013-06-13-0 -g09fcdfb
[ 29.800000] Backport generated by backports.git backports-20130531-13-g3d933e b
[ 29.840000] cfg80211: Calling CRDA to update world regulatory domain
[ 29.850000] cfg80211: World regulatory domain updated:
[ 29.850000] cfg80211: (start_freq - end_freq @ bandwidth), (max_antenna_gai n, max_eirp)
[ 29.860000] cfg80211: (2402000 KHz - 2472000 KHz @ 40000 KHz), (300 mBi, 20 00 mBm)
[ 29.870000] cfg80211: (2457000 KHz - 2482000 KHz @ 20000 KHz), (300 mBi, 20 00 mBm)
[ 29.870000] cfg80211: (2474000 KHz - 2494000 KHz @ 20000 KHz), (300 mBi, 20 00 mBm)
[ 29.880000] cfg80211: (5170000 KHz - 5250000 KHz @ 40000 KHz), (300 mBi, 20 00 mBm)
[ 29.890000] cfg80211: (5735000 KHz - 5835000 KHz @ 40000 KHz), (300 mBi, 20 00 mBm)
[ 30.190000] NET: Registered protocol family 10
[ 31.060000] ath: EEPROM regdomain: 0x0
[ 31.060000] ath: EEPROM indicates default country code should be used
[ 31.060000] ath: doing EEPROM country->regdmn map search
[ 31.060000] ath: country maps to regdmn code: 0x3a
[ 31.060000] ath: Country alpha2 being used: US
[ 31.060000] ath: Regpair used: 0x3a
[ 31.060000] ieee80211 phy0: Selected rate control algorithm 'minstrel_ht'
[ 31.070000] ieee80211 phy0: Atheros AR9330 Rev:1 mem=0xb8100000, irq=2
[ 31.090000] cfg80211: Calling CRDA for country: US
[ 31.090000] cfg80211: Regulatory domain changed to country: US
[ 31.090000] cfg80211: (start_freq - end_freq @ bandwidth), (max_antenna_gai n, max_eirp)
[ 31.100000] cfg80211: (2402000 KHz - 2472000 KHz @ 40000 KHz), (300 mBi, 27 00 mBm)
[ 31.110000] cfg80211: (5170000 KHz - 5250000 KHz @ 40000 KHz), (300 mBi, 17 00 mBm)
[ 31.120000] cfg80211: (5250000 KHz - 5330000 KHz @ 40000 KHz), (300 mBi, 20 00 mBm)
[ 31.130000] cfg80211: (5490000 KHz - 5600000 KHz @ 40000 KHz), (300 mBi, 20 00 mBm)
[ 31.130000] cfg80211: (5650000 KHz - 5710000 KHz @ 40000 KHz), (300 mBi, 20 00 mBm)
[ 31.140000] cfg80211: (5735000 KHz - 5835000 KHz @ 40000 KHz), (300 mBi, 30 00 mBm)
[ 31.580000] loop: module loaded
[ 31.640000] ip_tables: (C) 2000-2006 Netfilter Core Team
[ 31.770000] xt_time: kernel timezone is -0000
[ 31.870000] nf_conntrack version 0.5.0 (452 buckets, 1808 max)
[ 32.130000] ip6_tables: (C) 2000-2006 Netfilter Core Team
[ 32.390000] batman_adv: B.A.T.M.A.N. advanced 2013.2.0 (compatibility version 14) loaded
[ 37.780000] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready
[ 37.780000] device eth0 entered promiscuous mode
[ 37.800000] IPv6: ADDRCONF(NETDEV_UP): br-lan: link is not ready
[ 38.360000] eth0: link up (100Mbps/Full duplex)
[ 38.360000] br-lan: port 1(eth0) entered forwarding state
[ 38.370000] br-lan: port 1(eth0) entered forwarding state
[ 38.370000] IPv6: ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
[ 38.380000] IPv6: ADDRCONF(NETDEV_CHANGE): br-lan: link becomes ready
[ 40.370000] br-lan: port 1(eth0) entered forwarding state



This is my new usb , I have just unpacked...

[www.amazon.com]
Re: NEW OPEN WRT SUPPORT FOR TP-Link TL-MR10U smiling bouncing smiley
June 23, 2013 05:50PM
weired!

Quote

[ 8.640000] ohci_hcd: USB 1.1 'Open' Host Controller (OHCI) Driver
[ 8.680000] uhci_hcd: USB Universal Host Controller Interface driver
[ 8.710000] Initializing USB Mass Storage driver...
[ 8.710000] usbcore: registered new interface driver usb-storage
[ 8.720000] USB Mass Storage support registered.
USB driver are loaded.

But it seems the device does not recognize the USB stick.

Can you verify the functionality of the USB Stick with a computer or try a different one.

Personally, I'm a fan of the DTSE9H and they work usually without any trouble.

Matthias
Re: NEW OPEN WRT SUPPORT FOR TP-Link TL-MR10U smiling bouncing smiley
June 24, 2013 01:30PM
Hello
Matthias i am using DTSE9H and is new . i check with other DTSE9H new flas drives but the problem persist....
Re: NEW OPEN WRT SUPPORT FOR TP-Link TL-MR10U smiling bouncing smiley
June 24, 2013 05:34PM
strange, then the usb support is maybe broken in the Trunk-Version I had.

I create a new image next week.. hopefully then fixed.
Re: NEW OPEN WRT SUPPORT FOR TP-Link TL-MR10U smiling bouncing smiley
July 07, 2013 07:09PM
I have not tried these images...

openwrt-ar71xx-generic-tl-mr10u-v1-squashfs-factory.bin (3.8 MB)
[mega.co.nz]

openwrt-ar71xx-generic-tl-mr10u-v1-squashfs-sysupgrade.bin (2.7 MB)
[mega.co.nz]



Edited 1 time(s). Last edit at 07/07/2013 07:11PM by jmac928.
Re: NEW OPEN WRT SUPPORT FOR TP-Link TL-MR10U smiling bouncing smiley
July 12, 2013 11:31AM
Me = Stupid
I made the image for the MR11U instead of the MR10U.

Currently creating new image based on current trunk, and I'm now able to test it too.

stay tuned
Re: NEW OPEN WRT SUPPORT FOR TP-Link TL-MR10U smiling bouncing smiley
July 18, 2013 03:38PM
Openwrt forum for this mini router

[forum.openwrt.org]
Re: NEW OPEN WRT SUPPORT FOR TP-Link TL-MR10U smiling bouncing smiley
July 19, 2013 02:37AM
With this price very soon this router will replace tl-wr703n
[www.aliexpress.com]
Re: NEW OPEN WRT SUPPORT FOR TP-Link TL-MR10U smiling bouncing smiley
July 27, 2013 03:24PM
Tl-Mr10u latest openwrt images

[downloads.openwrt.org]
Re: NEW OPEN WRT SUPPORT FOR TP-Link TL-MR10U smiling bouncing smiley
July 31, 2013 06:49AM
Just to give u and update:
I recognized, that there where some changes on OpenWRT-Wiki MR10U which indicates, that they tidied up a few things.
I gave it another try today (because of my bad internet I created an Amazon Clound-VM and worked there) and now there are other issues like a missing batman-adv driver sad smiley



Edited 1 time(s). Last edit at 07/31/2013 08:13AM by Matthias.
Re: NEW OPEN WRT SUPPORT FOR TP-Link TL-MR10U smiling bouncing smiley
July 31, 2013 08:15AM
Hi,
I updated the trunk-images with USB stuff included.

[stable.openwrt.piratebox.de]

But because of internal changes on the OpenWRT side, the batman-adv package is not included anymore. sad smiley
And I can't provide that in the short time I only have. sad smiley

The MR10U image is there - bedside the fact I have now a device, I can't test it because of other priorities and timing issues - sorry.

Thanks,
Matthias
Re: NEW OPEN WRT SUPPORT FOR TP-Link TL-MR10U smiling bouncing smiley
August 13, 2013 06:43AM
Matthias Wrote:
-------------------------------------------------------
> Hi,
> I updated the trunk-images with USB stuff
> included.
>
> [stable.openwrt.piratebox.de]
>
> But because of internal changes on the OpenWRT
> side, the batman-adv package is not included
> anymore. sad smiley
> And I can't provide that in the short time I only
> have. sad smiley
>
> The MR10U image is there - bedside the fact I have
> now a device, I can't test it because of other
> priorities and timing issues - sorry.
>
> Thanks,
> Matthias

Hello Matthias
I checked the image that you have build , but it keep reporting problems with usb.
so i tried the trunk image and it worked without problems .
Now i can confirm until now that works well
The working mr10u image Here [downloads.openwrt.org]
Now i have installed the Piratebox without any problem.thumbs up
snapshot of openwrt on mr10u



Edited 5 time(s). Last edit at 08/13/2013 01:31PM by jmac928.
Re: NEW OPEN WRT SUPPORT FOR TP-Link TL-MR10U smiling bouncing smiley
August 13, 2013 01:50PM
There is a super offer in Aliexpress ....mr10u for just 19.9 us dollars with free shipping .[www.aliexpress.com]... [www.aliexpress.com] ..... that is -16 us $ dollars from mr3020 that cost in Amazon 36 us dollars $ [www.amazon.com]. Amazing ......Plus the mr10u Has 2600mAh battery for portable Pb o just for energy backup (Note: The battery last 5 to 6 hours)..smileys with beer



Edited 1 time(s). Last edit at 08/13/2013 02:42PM by jmac928.
I built one

http://gobblin.se/u/clagnar/m/portable-piratebox/

I got this error when installing USB support on step 15 of the tutorial

root@OpenWrt:~# opkg install kmod-usb-uhci
Installing kmod-usb-uhci (3.10.10-1) to root...
Downloading [downloads.openwrt.org].
Multiple packages (kmod-usb-core and kmod-usb-core) providing same name marked HOLD or PREFER. Using latest.
Collected errors:
 * satisfy_dependencies_for: Cannot satisfy the following dependencies for kmod-usb-uhci:
 * 	kernel (= 3.10.10-1-eb42a11e4afad8cd723d889b48826c79) * 
 * opkg_install_cmd: Cannot install package kmod-usb-uhci.

but I ignored it because Matthias already put USB support in the install image, and it all worked out fine in the end
Re: NEW OPEN WRT SUPPORT FOR TP-Link TL-MR10U smiling bouncing smiley
September 15, 2013 07:08AM
ordered 1 of these, can't wait for it to be shipped out and tinker with it smiling smiley

edit --

i have completed the installation successfully and I can see the SSID - PirateBox and can connect to it but when i type google or refresh other site to redirect to the homepage it doesn't go thru the lobby page.

here is the network parameters before editing:

config interface 'loopback'
option ifname 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'

config globals 'globals'
option ula_prefix 'fdee:5dd2:e217::/48'

config interface 'lan'
option ifname 'eth0'
option type 'bridge'
option proto 'static'
option ipaddr '192.168.1.11' ##edited this before installing according to my ipconfig settings ###
option gateway '192.168.1.1'##edited this before installing according to my ipconfig settings ###
list dns '192.168.1.1' ##edited this before installing according to my ipconfig settings ###
option netmask '255.255.255.0'
option ip6assign '60' ## this is a new parameter for this device ##

here is the edited version located in the completed piratebox

config interface 'loopback'
option ifname 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'

config interface 'lan'
option ifname 'eth0'
option type 'bridge'
option proto 'static'
option gateway '192.168.1.1'
list dns '192.168.1.1'
list dns '8.8.8.8'
option netmask '255.255.255.0'

option ipaddr '192.168.1.1'

here is the before edit firewall config

config defaults
option syn_flood 1
option input ACCEPT
option output ACCEPT
option forward REJECT
# Uncomment this line to disable ipv6 rules
# option disable_ipv6 1

config zone
option name lan
list network 'lan'
option input ACCEPT
option output ACCEPT
option forward ACCEPT

config zone
option name wan
list network 'wan'
list network 'wan6'
option input REJECT
option output ACCEPT
option forward REJECT
option masq 1
option mtu_fix 1

after edit of firewall (note i have also tried phabell's instruction according to the step by step process... adding ' ' per parameter)
this is the current config now (without the ' ' )

config defaults
option syn_flood 1
option input ACCEPT
option output ACCEPT
option forward ACCEPT
# Uncomment this line to disable ipv6 rules
# option disable_ipv6 1

config zone
option name lan
list network 'lan'
option input ACCEPT
option output ACCEPT
option forward ACCEPT

config zone
option name wan
list network 'wan'
list network 'wan6'
option input ACCEPT
option output ACCEPT
option forward ACCEPT
option masq 1
option mtu_fix 1

any ideas? where i am wrong?



Edited 6 time(s). Last edit at 10/12/2013 05:57PM by ora600.
Re: NEW OPEN WRT SUPPORT FOR TP-Link TL-MR10U smiling bouncing smiley
October 12, 2013 06:05PM
Re: NEW OPEN WRT SUPPORT FOR TP-Link TL-MR10U smiling bouncing smiley
October 17, 2013 06:17AM
Hey guys can somebody help me with my issue?

Is there a possibility i can put my device in failsafe mode and reflash the image?
Re: NEW OPEN WRT SUPPORT FOR TP-Link TL-MR10U smiling bouncing smiley
October 17, 2013 09:04PM
which one did you order?
did you try to push that tiny button/hole a few times after powering it?
Author:

Your Email:


Subject:


Spam prevention:
Please, enter the code that you see below in the input field. This is for blocking bots that try to post this form automatically. If the code is hard to read, then just try to guess it right. If you enter the wrong code, a new image is created and you get another chance to enter it right.
Message: