Dnsmasq Failed

Posted by josephchrzempiec 
This forum is currently read only. You can not log in or make any changes. This is a temporary situation.
Now, this forum is in read-only mode. You find details Details hereContinue on /r/PirateBox
Dnsmasq Failed
February 23, 2016 09:09AM
Hello i finally got the piratebox working somewhat on my Raspberry pi board but when i go to sudo /etc/init.d/piratebox start i get this error message

enerating hosts file ....
Generating dnsmasq.conf .....
Generating Environment-config for lighttpd .....
Empty tmp folder
rm: cannot remove ‘/opt/piratebox/tmp/’: Is a directory
Copy over design files
[....] Starting hostap... :/usr/sbin/hostapd already running.
[....] Setting up wlan:Bringing up wifi interface wlan0
Setting up wlan0
[FAIL] Starting dnsmasq... : failed!
[ ok ] Starting droopy...:.
Generated HTML-Shoutbox File.
CRITICAL: /opt/piratebox/share/Shared modified 1 minutes ago. Threshold set to 5 minutes. Cannot update.
Generated HTML-DiskUsage File.
[....] Starting lighttpd...:2016-02-23 07:39:05: (network.c.409) can't bind to port: 80 Address already in use

Can someone please help me out
Re: Dnsmasq Failed
February 23, 2016 09:36AM
Hello i got it to work now. The problem was i follow the steps of
sudo apt-get -y install dnsmasq
sudo /etc/init.d/dnsmasq
stop sudo update-rc.d dnsmasq remove
the problem was somehow it didn't remove the update-rc.d dnsmasq so i did it again and tried to start it now it starts.

But only one problem remains when i go to upload a image it says I'm at 46% of my drive and it's a 8gb Sd card i forgot to expend the file storage. So when i go to do that in Sudo raspi-config it says this error message. Re-reading the partition table failed.: drive or resource busy. not sure what to do now?
Re: Dnsmasq Failed
February 23, 2016 12:30PM
Is there a reason you are not using the official image?
I guess you can not resize the partition because it is mounted,...
Re: Dnsmasq Failed
February 23, 2016 02:37PM
I couldn't get the official image to install correctly. I guess the lack of understanding of linux works. i couldn't get it to work. So Matthias said try this one Other install and i did after a lot of trial and error i got it up and running but can't extend the partition.
Re: Dnsmasq Failed
February 23, 2016 03:15PM
Wait a minute I think that is right 46% if using 8gb that is 3gb and something used.
Re: Dnsmasq Failed
February 24, 2016 01:02AM
Hello everything is great now the problem I was having with the dnsmasq error failed was because i had Lan network connection plugged in and that messed up everything but it was trying to do port 80 from the lan and the wireless also wanted to do port 80. So i disconnected lan network wire restart piratebox and it works now. thank you.
Re: Dnsmasq Failed
February 24, 2016 01:05AM
OK, that is great to hear. Did you open a thread regarding the problems with the official image? Maybe we can improve the functionality...
Re: Dnsmasq Failed
February 24, 2016 01:56AM
Hello stylesuxx no i didn't I do not know how to do that. Still a little new to piratebox.