Re: In two MR3020 same problem: it does not install piratebox [Solved]
July 17, 2014 08:03PM
Hoping to be clear enough, despite my floundering english...

I installed and runned succesfully my first PirateBox some weeks ago. Now I wanted to make new boxes.

I got some new MR3020, discovering they are a polish version! Any way I did not believe this was an issue and proceeded with the installation of PirateBox, finding myself in this situation:

telnet - > OK
changed password -> OK
ssh root@ -> OK

But... no trace of PirateBox, just the OpenWrt running.

I found that usb was not mounted; so no install.log, nothing. I could mount it by hand:

mount /dev/sda1 /mnt

... finding just the install folder, that I haved copied from a fresh unzip of before.

The OpenWrt image was the same I have been using in the first successful installation:


I've tried also to put this image on the usb pen and then trying to reflash with

mtd write -r openwrt-ar71xx-generic-tl-mr3020-v1-squashfs-factory.bin firmware

but the result was the same.

I tried everything again on an another MR3020 obtaining the same results...

Really grateful if someone could give me a hint...

Edited 2 time(s). Last edit at 07/18/2014 01:24PM by iamarf.
Re: In two MR3020 same problem: it does not install piratebox [Solved]
July 18, 2014 01:24PM
Solution found: by checking md5 hash of and of the openwrt image I discovered that those two files were incoherent. Actually, recently I downloaded but *not at the same time*
openwrt-ar71xx-generic-tl-mr3020-v1-squashfs-factory.bin ...
Now everything fine, thanks also to good conversation in the IRC.