hot smiley WARNING TP-Link TL-WR703N v1.7. hot smiley

Posted by Matthias 
This forum is currently read only. You can not log in or make any changes. This is a temporary situation.
Now, this forum is in read-only mode. You find details Details hereContinue on /r/PirateBox
hot smiley WARNING TP-Link TL-WR703N v1.7. hot smiley
January 28, 2013 04:48PM
In case you buy a TP-Link TL-WR703N check you version number on the package!! (and some are labled as v1.6 )

TP-Link changed the firmware so flashing with OpenWRT may cause bricking your device!!

More informations:

[wiki.openwrt.org]
[forum.openwrt.org]

It is mentioned to run since r35037 but afaik the usb drivers failed to build => no PirateBox!

Do NOT use the MR3020 image for a test.. you will only have SerialAccess - ethernet port will be dead!!!!
Re: hot smiley WARNING TP-Link TL-WR703N v1.7. hot smiley
February 08, 2013 12:10PM
I finally realized how my WR703N was bricked. -_-

Wish I didn't spent that $20
Re: hot smiley WARNING TP-Link TL-WR703N v1.7. hot smiley
February 09, 2013 02:32PM
Jimmy, I'm sorry for that.
I did a few stuff, that I get relevant information like this earlier.

Matthias
Hi,guys.We have a portable power bank specifically designed for TP-Link mini wireless router WR702N and WR703N,you can check it at [igg.me]
Re: hot smiley WARNING TP-Link TL-WR703N v1.7. hot smiley
March 11, 2013 06:21AM
702 can not run OpenWRT, checked it on Saturday again.
on 703 the current trunk image is confirmed to work.
Hello David,
Can you please url point me to the bin that do work OK? .... " 703 v1.7 the current trunk image is confirmed to work."
Thank you

nissim.zur@gmail.com
Re: hot smiley WARNING TP-Link TL-WR703N v1.7. hot smiley
April 02, 2013 11:19AM
Seems that I can update the custom-image for 703n soon and refresh the stable.openwrt.piratebox.de repository soon.
So, finally managed to build an almost all-inclusive image from trunk for the 1.7 WR703n.

It works just fine, except that I packaged losetup in busybox (the more in busybox, the better) so opkg will complains about missing dependencies (and should complains only about losetup, everything else is kernel built-in or included uin the firmware), so just add a --force-depends to it.

I've wrote a blog post about it, with files and a git for the build-env (and .config) used if you're interested.

[about.okhin.fr]

Have fun,
Share,

WIth datalove,
Okhin
Re: hot smiley WARNING TP-Link TL-WR703N v1.7. hot smiley
April 23, 2013 07:34PM
Hello guys, I dont know if you already knew but if you flash the build from attitude-adjustment instead of trunk everything works. I used this file wr703n attitude adjustement and followed the guide and everything worked fine on all 3 of my 1.7 devices.
Re: hot smiley WARNING TP-Link TL-WR703N v1.7. hot smiley
April 24, 2013 08:52AM
are you sure about the 1.7 devices.. a while ago I made a different experience :/
Re: hot smiley WARNING TP-Link TL-WR703N v1.7. hot smiley
April 24, 2013 02:18PM
Im pretty sure they were 1.7 devices. According to the openwrt wiki these ship with build number 120925. I went to the stock chinese firmware and that was the version on all 3. I got the file from this post OpenWRT Forum. I flashed that file and did the steps from the wiki to install piratebox and it all went without a problem on all three of my devices.
Re: hot smiley WARNING TP-Link TL-WR703N v1.7. hot smiley
April 24, 2013 03:39PM
ok fine, seems I have to mail david for updating the image-link
Re: hot smiley WARNING TP-Link TL-WR703N v1.7. hot smiley
April 27, 2013 12:43PM
Yesterday I flashed a wr703n (I guess it's a v1.7?) with Attitude Adjustment (12.09 final) which was released on the 25th April 2013.

I just followed Davids steps from the main mr3020/wr703n page, but used the firmware from openwrt.

Here's the details (Updating, I've now flashed two wr703n):

1st one I did:

3.14.4 Build 121204 Rel.41020n
WR703N v1 00000000

2nd one, but I think this is an older firmware:

3.12.11 Build 120228 Rel.43313n
WR703N v1 00000000

Reminders, more for myself than anything:

* Turn off wifi
* I used this image: openwrt-ar71xx-generic-tl-wr703n-v1-squashfs-factory.bin
* rename it to openwrt.bin, apparently the factory image borks on long names
* be patient, it takes a little while to get started

YMMV of course



Edited 2 time(s). Last edit at 05/29/2013 03:09PM by gbbgu.
all went well but the tl-wr703n will not find my usb
Re: hot smiley WARNING TP-Link TL-WR703N v1.7. hot smiley
January 28, 2014 09:27PM
Which image link did u use?
Which usb device did u use?
Does it have one partition formated as vfat ?
Has anyone been able to flash openWRT onto a TL-Link TL703N ( 3.17.1 Build 140120 Rel.56593n ) ?

I'd rather find a software fix rather than taking the old 703n from my Avalon ASIC miner, unsoldering the flash IC and resoldering it onto the new 703n....

Any help would be very grateful

Thanks
Re: hot smiley WARNING TP-Link TL-WR703N v1.7. hot smiley
June 28, 2014 11:07AM
3.17.1 Build 140120 Rel.56593n <- are those numbers from the ui ?
Normally you see the Device version on the box, on the circuit or at least on the package.

Matthias
Re: hot smiley WARNING TP-Link TL-WR703N v1.7. hot smiley
June 30, 2014 05:05PM
zeriux Wrote:
-------------------------------------------------------
> Im pretty sure they were 1.7 devices. According to
> the openwrt wiki these ship with build number
> 120925. I went to the stock chinese firmware and
> that was the version on all 3. I got the file from
> this post OpenWRT Forum. I flashed that file and
> did the steps from the wiki to install piratebox
> and it all went without a problem on all three of
> my devices.


I have the same device, same build number and used your recommended .bin. The OpenWRT works fine, but how did you get all the Piratebox stuff up and running? I'm hesitant when I get to:

> 8. Install the customized version of OpenWrt and PirateBox 1.0 with:

Isn't that going to flash a 'bricking-build' onto my WR703n?
Re: hot smiley WARNING TP-Link TL-WR703N v1.7. hot smiley
June 30, 2014 06:29PM
As far as I know, the WR703N image should work (tested on LibraryBox release)... so well, I can't give any guarantee ..


This is only my signature.
Re: hot smiley WARNING TP-Link TL-WR703N v1.7. hot smiley
June 30, 2014 07:51PM
I decided to just go ahead and try step number 8, but I can't seem to mount the USB. Perhaps it's not really working the way it should...

> root@OpenWrt:~# cd /mnt/usb
> -ash: cd: can't cd to /mnt/usb

So nothing to cd to. Let's see what 'dmesg' gives me. Device rebooted with USB plugged in:


[ 9.610000] PPP generic driver version 2.4.2
[ 9.860000] ip_tables: (C) 2000-2006 Netfilter Core Team
[ 10.080000] NET: Registered protocol family 24
[ 10.100000] ehci_hcd: USB 2.0 'Enhanced' Host Controller (EHCI) Driver
[ 10.110000] ehci-platform ehci-platform: Generic Platform EHCI Controller
[ 10.110000] ehci-platform ehci-platform: new USB bus registered, assigned bus number 1
[ 10.150000] ehci-platform ehci-platform: irq 3, io mem 0x1b000000
[ 10.170000] ehci-platform ehci-platform: USB 2.0 started, EHCI 1.00
[ 10.170000] hub 1-0:1.0: USB hub found
[ 10.170000] hub 1-0:1.0: 1 port detected
[ 10.200000] nf_conntrack version 0.5.0 (456 buckets, 1824 max)
[ 10.430000] ohci_hcd: USB 1.1 'Open' Host Controller (OHCI) Driver
[ 10.510000] usb 1-1: new high-speed USB device number 2 using ehci-platform
[ 14.290000] device eth0 entered promiscuous mode
[ 14.400000] eth0: link up (100Mbps/Full duplex)
[ 14.400000] br-lan: port 1(eth0) entered forwarding state
[ 14.410000] br-lan: port 1(eth0) entered forwarding state
[ 16.410000] br-lan: port 1(eth0) entered forwarding state


Unplugged the USB and tried again:

[ 102.600000] usb 1-1: USB disconnect, device number 2


Plugged the USB back in:

[ 113.140000] usb 1-1: new high-speed USB device number 3 using ehci-platform


So what am I doing wrong? Something simple or is the USB broken?



Edited 1 time(s). Last edit at 06/30/2014 07:52PM by lex.michdebox.
Re: hot smiley WARNING TP-Link TL-WR703N v1.7. hot smiley
July 01, 2014 02:28PM
Why didn't I try the easy way the first time?

So I used the webgui of the already installed OpenWRT to flash the firmware to the WR703n (3.14.4 build 120925 Rel. 33144n) and it worked just like the two MR3040's I made. Now if these things only had a little more range... Anyway, time to do some more fun stuff and set it up with an attractive name. Thanks again!
John
Re: hot smiley WARNING TP-Link TL-WR703N v1.7. hot smiley
November 13, 2014 09:13PM
Dangit Wrote:
-------------------------------------------------------
> Has anyone been able to flash openWRT onto a
> TL-Link TL703N ( 3.17.1 Build 140120 Rel.56593n )
> ?
>
> I'd rather find a software fix rather than taking
> the old 703n from my Avalon ASIC miner,
> unsoldering the flash IC and resoldering it onto
> the new 703n....
>
> Any help would be very grateful
>
> Thanks

I have a number of these Avalon units which were used for mining and now I want to convert them back to standard openwrt.
Units are identical to new, nothing unusual hardware wize.

TP-Link TL-WR703N
hardware version 1.6 (even confirmed on the Ethernet port sticker, 1.6)

However, everything I have tried from making my own build using the latest image builder to try both factory and sysupgrade failed, to using openwrt factory and even using original tp-link software.

Each time, the upgrade bricks the device.

More info in /etc

in a file called avalon_version
20131229
cgminer: 698d677
cgminer-openwrt-packages: aadd747+
luci: 346e3e7+

Wondering if anyone might have some insight.Hate to throw them out.

Thanks.
Re: hot smiley WARNING TP-Link TL-WR703N v1.7. hot smiley
November 14, 2014 09:07AM
Does failsafe mode?
which image file did you try?
Did you try serial access, maybe you can rescue the bricks... ?

(tp link software without striping the bootloader generates a not bootable device)
Re: hot smiley WARNING TP-Link TL-WR703N v1.7. hot smiley
March 31, 2015 01:39PM
I have one of these as well:
TL703N ( 3.17.1 Build 140120 Rel.56593n ) As reported by the UI.
Any attempt to flash a new OS via the UI results in error 18005.

If anyone has a clue of how to proceed I would be grateful!
Re: hot smiley WARNING TP-Link TL-WR703N v1.7. hot smiley
April 05, 2015 11:54AM
There are others that have the same issue. You can find that thread on OpenWrt forums[/code].

There is already a flag, that 3.17 hardware versions do not work: see [
piratebox.cc]

I'm sorry.


This is only my signature.
It works! PirateBox runs on the TL-WR703N v1.7 with latest firmware as of 2018-01-04

I realize that this is an old thread, but everything I can find says the same as this thread, "PirateBox won't run on the TL-WR703N v1.7." I can it can, and it does. I'm running it on one right now. I purchased the router mid-December, 2017 and got it up and running early January, 2018. Check out the blog post I made documenting the process.