Raspberry Pi Zero W - after cold shutdown - no content in browser window

Posted by SleepyHollow 
This forum is currently read only. You can not log in or make any changes. This is a temporary situation.
Now, this forum is in read-only mode. You find details Details hereContinue on /r/PirateBox
Raspberry Pi Zero W - after cold shutdown - no content in browser window
April 27, 2019 04:55PM
Hi there,

I installed piratebox on my raspi zero w. At first test everything went okay. I can upload and browse files via wlan.

I pulled the power cable and made no shutdown. The raspi starts again but the browser window is empty. SSH works. What happened with the landing page?


this is not good.

Alright I flashed it again. I want to use the zero headless but it seems not very useful. Without display you can't judge if it has really shut down. The led is hidden in the official red-white case and it is invisible.

Use case: I'm a teacher and want to power it up during lesson, share some files, collect some files and power it down after end of the lesson. I had to change the location and the same happens again.

If I had to fiddle around with termux on my android phone in order to shut it down cleanly then this is not useful. Data loss is not acceptable in this scenario.

Is there a way to run piratebox in a kind of stealth version which tolerates simple unplugging of power cable instead of a clean shutdown? I don't to want to use a powerbank and leave the raspi on during the whole day.

Re: Raspberry Pi Zero W - after cold shutdown - no content in browser window
June 13, 2019 07:49PM
I have a few Pi Zero W boxes that I run on batteries to take on the train with me. What I've ended up doing is adding an LED power indication light, and a button to press to power it down. You have to do a little soldering, unless you get the headers you can hammer in, but you still need to connect wires to the button and LED. I'm not great at soldering, but I've managed to pull it off. The button is super handy, and then the light is a clear way to know if the thing is really off. (I built them into travel soap cases, and didn't feel like having to open them any time I needed to power down.)

The button instructions are here:

These are the LED instructions I followed:

CAVEAT: I haven't messed around with the two that I set up this way for a while, and as I went through my bookmarks, I was reminded that I ran into trouble with kernel panics on boot due to something UART-related. The really odd thing is that both were set up the same way, but one freaked and the other didn't. I got caught up in other things before I had a change to figure it out. Worst-case scenario, you can downgrade to 1.1.3, which didn't give me the issue. (I may even have done this myself. I'll find out shortly, since I'm currently making a third battery-powered one for a play I'm in that's performed outdoors, so the audience can upload any photos they take.)
Re: Raspberry Pi Zero W - after cold shutdown - no content in browser window
October 10, 2019 11:13AM