Root page and core.db is html file with redirect to http://piratebox.lan/content.

Posted by smi 
This forum is currently read only. You can not log in or make any changes. This is a temporary situation.
Now, this forum is in read-only mode. You find details Details hereContinue on /r/PirateBox
smi
Root page and core.db is html file with redirect to http://piratebox.lan/content.
June 18, 2019 08:19PM
Setup:

- Rapberry Pi 3B
- piratebox_rpi2_1.1.4-11-05-2018.img


I have just installed piratebox, but I'm not sure what to do next. I've tried accessing it in the webbrowser and after a brief blank blank with only the word "redirect", the url is redirected to pirate.lan/content, but the page recieves an error: "Site is innaccessible" "err_connection_refused"

[update #1]

I've found the culprit, but not the solution yet.

[alarm@BwatduhPirat ~]$ cat /var/lib/pacman/sync/core.db
<html>
<head><title>Redirect...</title>
<meta http-equiv="refresh" content="0;url=http://piratebox.lan/content" />
<meta http-equiv='cache-control' content='no-cache, no-store, must-revalidate' />
<meta http-equiv='pragma' content='no-cache' />
<meta http-equiv='expires' content='0' />
</head>
<body>
Redirect
</body>
</html>

[update #2]

It's the same problem as [forum.piratebox.cc]

The time of my clock in piratebox is off saying it is 2018 and pacman cannot update.

[alarm@BwatduhPirat ~]$ pacman -Syu 
error: could not open file /var/lib/pacman/sync/core.db: Unrecognized archive format
...

[update #3]

I've tried..

sudo rm /etc/resolv.conf
sudo sh -c 'echo "nameserver 8.8.8.8" > /etc/resolv.conf '

and..

sudo date -s "20170523 1742"

and rebooted.

The time just goes back to April 24 2018 again.

[update #4]

Also, I tried the following without rebooting

[alarm@BwatduhPirat ~]$ sudo date -s "20170523 1742"
Tue May 23 17:42:00 UTC 2017
[alarm@BwatduhPirat ~]$ sudo rm -R /var/lib/pacman/sync
[alarm@BwatduhPirat sync]$ sudo pacman -Sy
:: Synchronizing package databases...
error: failed retrieving file 'core.db' from mirror.i3d.net : The requested URL returned error: 404
...
error: failed retrieving file 'aur.db' from mirrors.xtom.nl : SSL certificate problem: certificate is not yet valid
error: failed to update aur (download library error)
error: failed to synchronize any databases
error: failed to init transaction (download library error)


[alarm@BwatduhPirat piratebox]$ sudo systemctl status timesave
‚óŹ timesave.service - PirateBox timesave service
   Loaded: loaded (/etc/systemd/system/timesave.service; enabled; vendor preset: disabled)
   Active: failed (Result: exit-code) since Tue 2017-05-23 17:43:12 UTC; 38min ago
 Main PID: 279 (code=exited, status=0/SUCCESS)

Apr 24 00:31:59 BwatduhPirat systemd[1]: Starting PirateBox timesave service...
Apr 24 01:15:00 BwatduhPirat root[303]: /opt/piratebox/bin/timesave.sh: Sucessfully recovered date-time.
Apr 24 01:15:00 BwatduhPirat timesave.sh[279]: <13>Apr 24 01:15:00 root: /opt/piratebox/bin/timesave.sh: Sucessfully recovered date-time.
Apr 24 01:15:00 BwatduhPirat systemd[1]: Started PirateBox timesave service.
May 23 17:43:12 BwatduhPirat systemd[1]: Stopping PirateBox timesave service...
May 23 17:43:12 BwatduhPirat root[448]: /opt/piratebox/bin/timesave.sh: Current date-time is lower then saved one. Not saving!
May 23 17:43:12 BwatduhPirat timesave.sh[437]: <13>May 23 17:43:12 root: /opt/piratebox/bin/timesave.sh: Current date-time is lower then saved one. Not saving!
May 23 17:43:12 BwatduhPirat systemd[1]: timesave.service: Control process exited, code=exited status=1
May 23 17:43:12 BwatduhPirat systemd[1]: timesave.service: Failed with result 'exit-code'.
May 23 17:43:12 BwatduhPirat systemd[1]: Stopped PirateBox timesave service.



Edited 11 time(s). Last edit at 06/23/2019 12:17PM by smi.
Re: This site is inaccessible
June 20, 2019 01:13PM
Did you change the configuration? pirate.lan is not a domain we use in the latest version
Re: This site is inaccessible
June 23, 2019 10:43PM
Maybe you should use

sudo date -s "20170523 1742"
with a current date & time...
smi
Re: This site is inaccessible
June 23, 2019 10:58PM
I'm terribly sorry.

I thought "Enable Fake-Timeservice"
meant I needed to set it to a default fake datetime.

It was also unclear in the installation manual what to do after it has all been setup.
That I had to visit http://192.168.x.x/content/ instead of [192.168.x.x] I didn't know either.



Edited 2 time(s). Last edit at 06/23/2019 10:59PM by smi.